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abstract	 The handbook describes methods of creating
	 guilloches by means of CERBERUS®. 
	 CERBERUS® is supported by operating systems Windows NT/2000/XP.
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general provisions
CERBERUS® is designed for creating guilloche elements used to protect various printed products against 
forgery. CERBERUS® allows creating various backgrounds, rosettes, decorative borders as well as other 
guilloche elements.

Irregular guilloche elements can be created by 3D distortion of the original guilloche element. It is possible 
to specify necessary thickness of guilloche lines as well as create elements with variable lines thickness 
(overlay of images). The program provides for modulation of guilloche elements parameters under a certain 
law or based on a bitmap image.

Guilloches are created by the Users in the interactive mode. Intermediate products are saved in the internal 
data format. The achieved results are exported in vector format into a PostScript File.

The software is protected against unauthorized launch (by a password and a digital key) and access to data 
files (by a password to open the files and encode the data).
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system requirements
CERBERUS® is supported by the operating system Windows 2000/XP, so it can be installed on any PC.

CPU 1200 MHz or higher
RAM 512 Mb or higher
Minimum 200 Mb free HDD space
Color monitor 1024x768 or higher
CD-ROM
1 free USB 2.0 port for the security key
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UNIT 1. GENERAL INFORMATION

The first unit introduces the notion of «Guilloches». We will answer the question why guilloches are 
used as a means of protection, and describe the requirements for creating guilloches. Regular and 
irregular guilloches will be studied in this unit. We will also learn where guilloches can be used and 
where guilloches would be unnecessary. Further we will find out about the basic guilloche images 
provided by CERBERUS® and define the basic notions used in the program. User interface is 
introduced in this chapter as well. In conclusion we will try to create simple guilloche elements. 

Introduction

Before we start learning about CERBERUS®, we will try to understand the notion of «guilloche» and 
why guilloche is used as a means of protection. If we go back in time, it turns out 
that the guilloche technology has been in use for many centuries now. 

Initially, when there were no computers, guilloches were made on special automatic machines. By 
means of rotary and forward movements an image composed of fine lines that looked like sinusoid 
curves was drawn on printing plates. Then, this picture could be printed (replicated) on sheets of 
paper. A widely known toy called spirograph is the simplest example of such printing machines.

The unique properties of each guilloche image created on such machines are determined by the 
settings of a machine mechanism, and having changed some parameters of the mechanism, one will 
create another picture. Thus, it is possible to make one and the same guilloche element only on the 
same machine and knowing the exact settings of this machine. A human being is unable to repeat 
all smooth curve lines of any guilloche accurately, because any slightest deviation from the original 
pattern leads to distortion of the pattern appearance. That is why guilloches were used to protect 
securities.
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Nowadays, with the development of copier machines, guilloches should have ceased to be used to protect 
documents and securities against forgery. Practice shows, however, that guilloches are still in great demand. 
Moreover, guilloches applied to protect printing matters, should be used in combination with other protection 
technologies such as specially designed paper with watermarks, special security inks, and printing methods. 

A guilloche must meet certain requirements to perform its protection functions. Otherwise, even if it is drawn 
in a special program it will not be protective and can be easily forged. First of all, these requirements apply 
to geometrical characteristics: a pattern must feature a complex structure and a typical step of about one 
millimeter; it can be made of positive or negative lines (which are most difficult to forge). Lines width is also 
regulated and must not exceed 40..70 micron and 50..90 micron for positive and negative lines, respectively. 
These figures do not allow accurate imitation of any line on a copier machine. The lowest line thickness limit 
depends on the technological capabilities used for printing (for example, offset printing).

A guilloche pattern must be made of a large number of identical elements and, at the same time, have 
a random structure. Otherwise, if one element of a picture is imitated, it will not be difficult to reproduce 
the whole pattern entirely. Multicolored guilloche compositions increase the protection level of a printed 
document significantly. 

Let’s see how guilloche drawing methods have changed due to state of the art development. In general, the 
process of preparing a protected document using computer technologies can be described in the following 
way. The user creates vector guilloche patterns by means of special software by specifying construction 
parameters known only to him. Then in a layout program separate guilloches are merged into a single 
composition, text data is added and color separation is made. After that, depending on the technology, the 
graphical image is transferred onto printing plates for further printing.

Obviously, to prevent leakage of information on the protected document manufacturing process, a reliable 
security system is required at each phase of the production process. Both printing plates and source 
computer files must be protected. In order to reproduce an exact copy, the minimum requirement is 
performing the whole technological process employed for creation of the original document.
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It should be noted that guilloches are used first of all for traditional printing methods, for example, for offset 
printing. The fact is that due to the technological peculiarities of offset printing there is a difference between 
a printed copy and the source file. That is why it is impossible to reproduce the source computer file by 
scanning its printout. Moreover, various graphic tracing programs are also useless, because they cannot 
single out separate component lines among a large number of intersecting lines.

Use of guilloches to protect ink-jet printing matters is open to criticism, but their effective decorative 
application is beyond any doubt. Guilloches printed by process colors (CMYK) as normal screened images 
serve the same purpose, because in this case only pattern appearance slightly resembling a guilloche is 
retained. 
 
Guilloches are stored in computers in vector format, and they can be opened in any graphics editor, 
supported by PostScript format, compilation is carried out in commonly used layout programs. 

But why is it impossible to draw «a guilloche» manually and why is special software required? You can 
answer these questions after reading this guide. 
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The Principle of Drawing Guilloches in CERBERUS® 

Before we start drawing a guilloche, we should first decide on its type: whether it will be a background, a 
rosette, a border, or another element. Each type of guilloche pattern is characterized by a typical shape, 
so a rosette looks like a circle, and a border resembles a straight line, etc. Evidently, to be able to design a 
guilloche element, one needs some starting point. «Base» plays the role of such foundation in CERBERUS®, 
i.e. the base line used for building a guilloche element. It is used, so to say, as a coordinate system. 

In CERBERUS®, various «Bases» are available for creating all possible guilloches of different shapes. 
So, «Base» called «Ellipse» is used for drawing rosettes, and «Line segments» can be used for borders. 
Moreover, it is possible to use a free form curve line through import from vector format. All these facts 
provide wide possibilities for creating various guilloches of sophisticated shapes.
 
The choice of «Base» determines the design of a future guilloche. To shape the future guilloche it is 
necessary to limit the area for building the pattern. For this purpose «Envelope» has been introduced in 
CERBERUS®. «Envelopes» are lines created on the «Base» with the help of special User-defined functions 
that serve to put guilloches into the required shape. To specify functions, Fourier series as well as an 
analytical form introduced as a mathematical expression can be used. 

Finally, to complete creation of a guilloche element, the space between «Envelopes» must be filled in with 
crossing smooth lines under a certain rule. «Fillers» perform this function in CERBERUS®. «Fillers» are a 
multitude of lines created on the basis of two «Envelopes» with the help of User-defined functions. Lines fill 
in the space between two «Envelopes». 

Creating guilloches is similar to building a house. The choice of the «Base» is the lay of the foundation, 
drawing «Envelopes» means building the walls of the house, «Fillers» serve as a final finishing. Of course, 
this comparison is rather relative, but on the whole it gives a clear idea of the way guilloches are created.
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Terms and Definitions Used in CERBERUS® 

«Guilloche element» – is a set of separate «Bases», «Envelopes», «Fillers» forming a single graphical 
guilloche pattern. In CERBERUS®, a document can contain a number of such elements. 

«Base» – is the base line that defines the appearance of the created guilloche element. Each «Base» 
belongs to a certain type determined at the time of creation. 

«Base Type» is a set of characteristic «Base» properties that determine curves shape, for example, an 
ellipse, a segment, etc. 

«Envelope» – is a line, created on the «Base» with the help of User-defined «Functions». 

«Filler» – is a set of lines created on the basis of two «Envelopes» with the help of a User-defined 
«Function». These lines fill in the space between two «Envelopes». 

«Function» means User-defined objects used to describe curves and surfaces and determine the rules for 
changing different parameters. 
 
«Filter» is a special tool for modifying the original guilloche element. For example, 3D-deformation, frames 
and kaleidoscopes creation possibilities are realized through «Filters» in CERBERUS®.
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Program Interface 

Run CERBERUS.exe to launch the program. The program verifies availability of the electronic security key 
and launches after successful verification.

CERBERUS® stores the saved files in a special internal format, type of documents is *.crb. Such documents 
are also provided with a special password protection against unauthorized use.
CERBERUS® has a multi-windows interface enabling concurrent editing of several documents and exchange 
of elements from different documents. 

The working area is used for visual monitoring of the created guilloche element. «Bases», «Envelopes» 
and «Fillers» created by the User are displayed in the working area. Measuring bars are used to determine 
dimensions of the created guilloche elements.
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File -> New – (Ctrl+N) creates a new document. A new window is created 
with an empty document. The document gets the Untitled.crb name. After 

the new document has been created, it is necessary to set its parameters. 
File -> Open – (Ctrl+O) opens a previously saved document. 

If the document is already open for editing, 
this document window becomes active.

 File -> Close – (Ctrl+W) closes the currently open document.
File -> Save – (Ctrl+S) saves the edited document on the disk. If a new 

document is saved it gets the ‘untitled.crb’ name by default.
 File -> Save as … – to save the edited document 

on the disk under a different name. 
File -> Revert – reverts to the saved version of the file. 

File -> Import – (Ctrl+I) places an earlier saved document into the current 
document (*.crb, *.ai, *.emf formats are supported).

File -> Export – (Ctrl+E) exports the created 
guilloche element into a PostScript-file.

File -> Print (Ctrl+P) prints out the active document.
File -> Exit – (Ctrl+F4) completes work with the program. 

If the edited document has not been saved, the program offers to save it.

The above menu also shows the history of earlier 
used files to enable fast access to the latest of them.

Main Menu 

Menu items available in CERBERUS® are listed below.

The «File» menu contains commands to manage document files:
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The «Edit» menu contains commands, which allow editing documents and provide access to their 
parameters.

The «Wizard» menu contains commands to manage «Functions»

Edit -> Undo – (Ctrl+Z) cancels editing (rollback).
Edit -> Redo – (Shift+Ctrl+Z) repeats editing.

Edit -> Copy – (Ctrl+C) places the selected element into the clipboard.
Edit -> Paste – (Ctrl+V) places an element from the clipboard into the current document.
Edit -> Configuration – calls up the program and document configuration settings menu.

Wizard -> Rosette Wizard – calls up the Rosette Wizard dialogue window.
Wizard -> Border Wizard – calls up the Border Wizard dialogue window.

Wizard -> Background Wizard – calls up the Backround Wizard dialogue window.
Wizard -> Effects Wizard – calls up the Effects Wizard dialogue window.
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The «View» menu provides access to commands of interactive editing and document parameters 
adjustment.

View -> Zoom In – zooms in preview by 25%.
View -> Zoom out – zooms out preview by 25%.

View -> Print size – sets the preview scale as 100%.
View -> Zoom to page – sets the preview scale to display the whole page.

View -> View – list of the saved views.
View -> Save View – saves current zooming and position.
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The «Workspace» menu includes window management commands:

Workspace -> Main Toolbar – shows / hides the Main Toolbar
Workspace -> Quick bar – shows / hides the Quick bar

Workspace -> Guilloche manager – shows / hides the Guilloche manager
Workspace -> Base – shows / hides the Base window

Workspace -> Envelope – shows / hides the Envelope window
Workspace -> Filler – shows / hides the Filler window

Workspace -> Function libray – shows / hides the Function library window
Workspace -> Function editor – shows / hides the Function editor window

Workspace -> Function preview – shows / hides the Function preview window
Workspace -> Pen tool properties – shows / hides the Pen tool properties window

Workspace -> Filters – shows / hides the Filters window

* In case this command window is docked, it will be always displayed on the screen.
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The «Help» menu provides access to supplemental information about the program

Shortcuts can be assigned to all menu commands.

Help -> Contents – calls up the context related help system. 
Help -> About… – calls up the information dialogue window. 

The «Window» menu includes window management commands:

The lower part of the window displays the list of open documents. The current document is ticked.

Window ->Cascade – arranges windows in a cascade.
Window -> Tile Horizontally – arranges windows horizontally.

Window -> Tile Vertically – arranges windows vertically.
Window ->Minimize all – minimizes all windows.

Window ->Arrange – arranges minimized windows.
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«Quickbars»

CERBERUS® provides special bars that enable calling up some functions 
by one click.

For Users convenience these bars can be docked in the upper part of the 
screen or float free. Users can also change the order and position of the 
docked «quickbars» relative to each other. 
In order to hide or show the «quickbar» one should choose the required 
item in the menu that drops out by clicking the right mouse button. It 
is also possible to show / hide the Tool Bar and QuickBar using the 
«Workspace» menu. 

Undocked «quickbars» can be temporarily hidden by clicking the ~ button 
(by default).

File Bar

Main Bar

Marking

Tools Bar

View

Apply

Zoom
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Settings

Program and current file configuration settings are made in the «Configuration» 
menu.

Description
 
A text description can be introduced in the Notes working field. 
File author’s name can be introduced in the Author working field. 
The User can protect data files by encoding the contents. It is impossible to 
open such files without the password. For encoding one should enter the 
password in the Password working field and save the file. 

The User is responsible for protecting Postscript-files, as well as other 
temporary files in workflow containing guilloche elements, against unauthorized 
access.

Units and precision

A program working field can have dimensions in millimeters and inches. Lines 
width can be set in millimeters, units, inches and microns. 
In numeric values the number of digits after the point is set in Precision.
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Page Setup
 
The size of the working field is set in this tab. One can choose preset sizes or 
sizes can be introduced by the User. 

Plotting parameters
 
Relative parameter [Quality] influences the accuracy of creating guilloche lines. 
By default the quality value is 6. You can vary it within narrow limits. When 
quality value is lower calculating speed increases while accuracy of lines 
creation decreases.
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Grid & Guidelines
 
Grid and guidelilnes parameters as well as color are set in this tab. 

ShortCuts
 
Shortcuts can be assigned to almost all the «Functions». In order to do this 
choose the required «Function» in the «Functions» tree-list, place the cursor in 
the shortcuts working field and press the required keys combination.
The list of assigned shortcuts can be exported to a text file and then printed.
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Command Windows 

CERBERUS® provides special command windows for managing various «Functions». They can be called up 
from the Workspace menu. 

Guilloche Manager – the window for displaying all document elements as a tree
Base – the window for editing the «Base»
Envelope – the window for editing the «Envelope»
Filler – the window for editing the «Filler»
Function library – the window for displaying all «Functions» used in the document
Function editor – the window for editing the selected «Function». It can vary depending on the selected 
«Function» type.
Function preview – preview of the current «Function». It is possible to display the «Function» as a graph or 
halftone filler for Fourier series.
Pen tool properties – the window for editing Pen tool properties. 
Filters – the window for the list and order of the used «Filters». 

Command windows can be single or grouped when several command windows are joined in one and 
navigation within them is done by clicking the tab with the heading.
Command windows can be floating or docked. Floating windows are placed free above the working field of 
the document. Docked windows ‘stick’ to the right or left part of the screen, at that the working field of the 
document decreases.

Floating windows can be temporarily hidden by pressing the ~ (tilda button) (by default).
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Changing color of the element
By default the color of the created objects («Base», «Envelope», «Filler») is black. It is possible to change 
colors and set the filling for the «Envelopes» and «Fillers». In order to change the color it is required to select 
the object and click the selected palette color by the left mouse button for changing the stroke, and by the 
right mouse button for changing the filling.
If the User is not satisfied by the palette colors, they can be changed. A dialogue window is called up by a 
double click on the palette element for changing color parameters of the current palette element.
Changes of the palette colors do not affect the current object colors.

Apply
The software provides several kinds of changes application:
	 •	 Entering a numeric combination from the keyboard
	 •	 Changing the working field by icons – arrows
Changing the value from the keyboard: arrows up and down add one unit to the value, the same thing done 
by SHIFT adds ten units.

The changes will apply only after clicking Apply icon or pressing Enter on the keyboard. 

In order to enable displaying in the interactive mode click Apply icon and press and hold «Alt» button at the 
same time, at that the icon of this button will display as ‘pressed’. 

For quitting the interactive mode click Apply button. 
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Guilloche Manager 

The «Guilloche manager» allows controlling individual guilloche elements, creating new elements, 
duplicating and deleting them.

A guilloche is displayed like a tree, its elements are «Bases», «Envelopes» and «Fillers». Selection of a tree 
element results in marking the respective guilloche component in the working area. 
The  and  icons specify element visibility and its filling accordingly.

The following commands can be used in the Guilloche Manager: 

Create a new guilloche group

Create a new «Base»

Create a new «Envelope»

Create a new «Filler»

Duplicate element or guilloche-group

Delete unit or guilloche-group

Show/hide element in the working area

Show/hide element filling in the working area
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The right mouse button calls up a dialogue window for a guilloche-group. 
The following commands are available:

Rename – to change the name of the selected guilloche group 
Copy – to place the selected element into clipboard

Paste – to place the element from clipboard into the current document
Duplicate – to make a copy of the selected element 

Delete – to delete the selected element 
Fragments – to switch the «Guilloche manager» into fragment edit mode that 

specifies the order of displaying guilloche parts 
Order – to change the order of displaying guilloche groups in the working area

To Front – to move the guilloche-group to the forefront 
To Back – to move the guilloche group to the background

Forward one – to move the guilloche group one level up
Back one – to move the guilloche group one level down

New – to create a new element 

Base – to create a new «Base» 
Envelope – to create a new «Envelope» 

Filler – to create a new «Filler» 
Guilloche – to create a new guilloche-group 

 
 Properties – to call up the «Base», «Envelope» or «Filler» window
Pen Parameters – to call up the Pen Parameters dialogue window 
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Creating a Simple Guilloche on the model of Rosettes 

The first step in practical mastering the program would be creating a simple rosette. 

1.	 First, with the help of Ctrl+N command create a new document and specify its parameters.

	 •	 Call up the Configuration dialogue window to specify the required parameters and the 
		  working area format. Let’s set the following values for our example: page width – 50 mm, 
		  page height – 50 mm.

You can enter your name in the line [Author], add some comments and set a password. If you 
introduce a password, the program will require to enter it when opening the saved file. It is 
impossible to open any file without knowing the password, so make sure you remember it or 
write the password down.

	 •	 The relative parameter [Quality] influences the accuracy of guilloche lines creation. By default 	
		Q  uality is qual to 6. You can vary this value within narrow limits. When Quality value is lower 	
		  calculating speed increases while accuracy of lines creation decreases.
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2.	 Create a «Base». 

	 •	 Create a new «Base» in the Guilloche Manager

	 •	 Choose «Ellipse» as a «Base» type
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	 •	 So, we have just created a new «Base», on which a rosette will be created.

	 •	 «Base»parameters are set by default according to the working area format, and in our case there is 	
		  no need to modify them.

	 •	 The results of these operations are saved in ‘sample_1_01.crb’.
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3.	 Create «Envelopes». Now we will create two «Envelopes» in order to shape our 
rosette.

	 •	I n «Guilloche manager», run command New -> Envelope to create the 		
		  «Envelope»

	 •	 So, a new «Envelope» with default parameters is created and named 		
		  ‘Envelope’. In our case, the following properties for a new «Envelope» should 	
		  be changed:
		

Amplitude = 5 mm
		  Displacement = 5 mm
		  Frequency = 9
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	 •	 The «Envelope» we’ve just created is shown on the right 

	 •	 Now we need to duplicate the «Envelope». The new element will be called «Envelope1».
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	 •	L et’s set the following parameters for «Envelope1»:

	 •	I t is possible to set lines color and width by calling up Pen Properties window.

		A  mplitude = 2 mm
		  Displacement = -5 mm
		  Frequency = 7
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When creating «Envelopes» we used a pre-defined «Function» – «Sin». As you might have already guessed, 
it is a common sinusoid. So, we have built two «Envelopes» – the lines between which the guilloche will be 
created. You can paint these «Envelopes» with different colors to distinguish one Envelope from the other. 
The result is shown in file ‘sample_1_02.crb’.
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4.	 Creating a «Filler».

Create a new «Filler» in the Guilloche Manager

	 •	A s a result a new «Filler» with default parameters will be created. 
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	 •	 The result is saved in file ‘sample_1_03.crb’.

In the end, it is possible to make the auxiliary «Base» – ellipse invisible. To do this, just tick off this icon in 
Guilloche Manager for the «Base». 
So, you have successfully completed creation of your first guilloche element. Now, you can experiment 
on this rosette on your own: try to vary the parameters of «Envelopes» and «Fillers» within narrow limits. 
Available samples are in files: sample_1_031.crb, 
sample_1_032.crb, sample_1_033.crb, sample_1_034.crb, 
sample_1_035.crb and sample_1_036.crb.

So, you’ve just learnt the principle of making a guilloche in 
CERBERUS®:

1. A «Base» is selected
2. «Envelopes» are built 
3. «Filler» is created between the «Envelopes» 

As you will see later, the same creation mechanism is also 
applicable to borders, backgrounds and other guilloche elements.

Let’s modify the following 
parameters of our rosette: 

Envelope 1 = Envelope
Envelope 2 = Envelope1

Frequency = 8
Filling = 80%

Lines in group = 9
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Creating a Border 

In this section we will try to create a border. First, create a new document with the help of command New 
Ctrl-N. Same as in the previous section, let’s first decide on the size of our future border. To this end, let’s set 
the following values in the «Configuration» dialogue window: Width = 50 mm and Height = 50 mm. 

In order to create a border, we will need a «Base» of the «Line segment» type, two «Envelopes», and a 
«Filler». Let’s also make use of the Functions Library in file ‘lib1.crb’. Import this file, so the Functions will 
become available in our document.

1. Let’s prepare the «Base». 

•	I n Guilloche Manager, create a «Base» of the «Line segment» type. The Base will be created with 		
	 default parameters. 

2. Now let’s create «Envelopes». 

•	 Using the Guilloche Manager, create a new « Envelope » with the following parameters:
		  Base = Base
		  Function = Fn1
		A  mplitude = 2 mm
		  Displacement = -5 mm
		  Frequency = 7

•	 Make a copy of the first «Envelope» and then change the following 
	 parameters for this new copy: 
		A  mplitude = -2 mm
		  Displacement = 5 mm
		
The result is saved in file ‘sample_2_02.crb’.
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3.	 Creating a «Filler». 

The result is in file ‘sample_2_03.crb’.
	

Now, you can experiment on our border on your own. You can look up some possible versions in these files: 
sample_2_031.crb, sample_2_032.crb, sample_2_033.crb, sample_2_034.crb, sample_2_035.crb, sample_
2_036.crb.
	
We have now made sure that there is little difference between the process of creating rosettes and borders. 
So, the principle of drawing a guilloche has remained the same.

Make a new «Filler» with the 
following parameters:

		  Envelope 1 = Envelope
		  Envelope 2 = Envelope1
		  Frequency = 8
		  Filling = 80%
		L  ines in group = 11
		  Phase = 288
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Creating Backgrounds 
	
Now it’s time to learn how to create guilloche backgrounds. To begin with, let’s make a simple background in 
A5 format (210х148 mm). Set the following values in the document parameters: 
Width = 210 mm, Height = 148 мм.
	
When creating a background, we’ll make use of one «Base» of the «Line segment» type, two «Envelopes», 
and one «Filler».
	
1.	 Create a «Base»

•	I n Guilloche Manager, create a «Base» of the «Line segment» type. A «Base» with default parameters 	
	 will be created.

2.	 Create «Envelopes»

•	 Create the first «Envelope» with the following parameters:
		A  mplitude = 0 mm
		  Displacement = 70 mm
		  Frequency = 1

•	M ake a copy of this «Envelope» and change the following parameter:
		  Displacement = -70 mm
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3.	 Creating a «Filler»

As a result of the above operations the background shown below has been created. It is saved in file 
‘sample_3_03.crb’. 
	

Set the following parameters 
for a «Filler»:

		G  roups = 20
		  Envelope 1 = Envelope
		  Envelope 2 = Envelope1
		  Frequency = 25
		  Filling = 175%
		L  ines in group = 1
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So, a background in CERBERUS® is nothing else but a very wide border. The created background, of 
course, has no practical value because its cells are too big. You can increase the number of Groups and 
Frequency, let’s say, fivefold in order to create a background with smaller cells.
	
The background we have created is regular; it means that one can reconstruct it having only a tiny fragment 
(a repeat). CERBERUS® also allows creating irregular backgrounds. We will describe them later on. 

By changing the parameters of «Fillers» it is possible to achieve the results given in files: sample_3_031.crb, 
sample_3_032.crb, sample_3_033.crb, sample_3_034.crb, sample_3_035.crb and sample_3_036.crb.

Task. To make your skills of creating the simplest guilloche elements stronger, try to create an original 
rosette, border and background on your own.
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UNIT 2. COMPOUND AND COMBINED GUILLOCHES 
This unit describes the principles of creating complex guilloche elements by means of various 
methods, and touches upon creating multicolored guilloches. 

Principles of Creating Compound Guilloches 

In examples of Unit 1 we used only one «Filler» to create guilloche elements. Based on the 
sample of a compound rosette we will describe the principle of creating compound guilloches. 
Let’s use the following method to create a complex guilloche element: let the rosette expand 
from its center by adding new «Envelopes» and creating new «Fillers» between them.

To start with, create a new document, in 90x70 mm format. Then, make a simple rosette. 
Select the – «Ellipse»-type «Base», 10 x 10 mm in size, 
and build two «Envelopes» on this «Base».

1st Envelope: Envelope
Base = Base

Function = Cos
Amplitude = 0 mm

Displacement = -4.5 mm 
Frequency = 0

2nd Envelope: Envelope1
Base = Base

Function = Cos 
Amplitude = 0 mm

Displacement = -2 mm
Frequency = 0

3rd Envelope: Envelope2
Base = Base

Function = Cos 
Amplitude = 2 mm

Displacement = 0 mm
Frequency = 6
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1st «Filler»: Filler
Envelope 1 = Envelope1
Envelope 2 = Envelope2

Function = Sin
Groups = 1

Frequency = 6
Filling = 100%

Displacement = 0% 
Lines in group = 8

2nd «Filler»: Filler1
Envelope 1 = Envelope 1

Envelope 2 = Envelope
Function = Sin

Groups = 7
Frequency = 24

Filling = 100%
Displacement = 0% 

Lines in group = 1

Then, create two «Fillers» with the following parameters:
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Following the above operations step by step, we have created the central part of the future rosette. You can 
check whether all operations were completed correctly by comparing the created result to the sample given 
in file ‘sample4_01.crb’
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Let’s continue creating our guilloche element by adding new «Envelopes» and «Fillers»

4th Envelope: Envelope3
Base = Base

Function = Fn5
Amplitude = 2 mm

Displacement = -5 mm
Frequency = 6

5th Envelope: Envelope4
Base = Base

Function = Fn5
Amplitude = -1 mm

Displacement = 10 mm
Frequency = 18

Phase = 180 deg 
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4th «Filler»: Filler3
Envelope 1 = Envelope 4
Envelope 2 = Envelope3

Function = Sin
Groups = 1

Frequency = 13
Filling = 100%

Displacement = 0%
Lines in group = 11

3rd «Filler»: Filler2
Envelope 1 = Envelope2
Envelope 2 = Envelope3

Function = Sin
Groups = 1

Frequency = 9
Filling = 100%

Displacement = 0%
Lines in group = 11
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The result of the above operations is in file ‘sample4_02.crb’.
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Let’s make our rosette even more complicated by adding several «Bases», «Envelopes» and «Fillers»: 
•	 Create a new «Base» Base1 of «Polygon» type with the following parameters: 
		  Width = 46 mm
		H  eight = 46 mm
		  Number of Sides = 5
		  Turning Angle = 18 deg.
		  Sliding Rotation – disabled 

•	A dd one more «Envelope» – Envelope 5 with the following parameters: 
		  Base = Base1
		  Function = Fn2
		A  mplitude = -1 mm
		  Displacement = 1 mm
		  Frequency = 20
		  Phrase = 90 deg.

•	A dd one more «Filler» – Filler4 with the following parameters: 
		  Envelope 1 = Envelope4 
		  Envelope 2 = Envelope5
		  Function = Sin 
		G  roups = 20
		  Frequency = 20

•	 Create a new «Base» – Base2 of «Ellipse»-type with the following parameters:
		  Width = 45 mm
		H  eight = 35 mm
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•	 Create a new «Envelope» – Envelope 6 with the following parameters 
		  Base = Base2
		  Function = Fn5
		A  mplitude = 1 mm
		  Displacement = 10 mm
		  Frequency = 40

•	 Create a new «Filler» – Filler5 with the following parameters: 
		  Envelope 1 = Envelope5 
		  Envelope 2 = Envelope6
		  Function = Sin 
		G  roups = 18
		  Frequency = 17

•	 Create a new «Envelops» – Envelope7 with the following parameters:
		  Base = Base2 
		  Function = Fn5
		A  mplitude = 1 mm
		  Displacement = 12 mm
		  Frequency = 40

•	 Create a new «Filler» – Filler6  with the following parameters: 
		  Envelope 1 = Envelope6 
		  Envelope 2 = Envelope7
		  Function = Sin 
		G  roups = 4
		  Frequency = 1
		  Filling = 0%
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Our rosette has now got its final appearance – see ‘sample4_03.crb’. So, you have already learnt how 
to make complex compound guilloches. The same technique can be applied to building borders and 
backgrounds.
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	 For example, you can now try to create a border similar to the one shown below (sample5_02.crb) on 
your own. 
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Radial «Fillers»

Let’s look at the principle of creating radial «Fillers». In contrast to a linear «Filler» where lines go along 
«Envelopes», in case of a radial «Filler» its lines go across «Envelopes». Such an arrangement of lines 
allows creating guilloche elements made of divergent lines. 

Now let’s look closer at this type of «Fillers» based on the following example. First, create a new document in 
format 100 x 100 mm.

As a «Base» we’ll use «Ellipse», 50 x 50 mm in size. Then we’ll create two «Envelopes» with the following 
parameters:

1st «Envelope» Envelope 
Base = Base
Function = Sin
Amplitude = 0 mm
Displacement = -20 mm
Frequency = 1
Phase = 0 deg.

2nd «Envelope» Envelope1 
Base = Base
Function = Sin
Amplitude = 0 mm
Displacement е = 20 mm
Frequency = 1
Phase = 0 deg.
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Envelope 1 = Envelope 
Envelope 2 = Envelope1

Function = Sin 
Direction = 

Groups = 50
Frequency = 5
Filling = 100%

Lines in group = 3

Then, create one «Filler» with the following parameters:
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Obviously, the main difference of such «Filler» is that the lines go from one «Envelope» to the other. This 
sample is saved in file ‘sample5_01.crb’. 

Some other versions of radial «Fillers» are given in the following files: sample5_011.crb, sample5_012.crb, 
sample5_013.crb, sample5_014.crb, sample5_015.crb.



page 54

Creating Combined Guilloches 

As a rule, several «Fillers» are required to achieve the complex structure of a combined guilloche element. 
One can make the pattern more complicated by means of overlaying several «Fillers» one over another. 
This method allows creating «Combined Fillers», which consist of two or more different «Fillers».

Let’s consider the example of creating a «Combined Filler». To this end, first, create a new document in 
format A5 (210x148 mm). Then, create a background with the following elements:

«Base» of the «Line segment» type with default parameters

1st «Envelope»: Envelope
Base = Base
Function = Sin
Amplitude = 0 mm 
Displacement = -70 mm
Frequency = 1
Phase = 0 deg.

2nd «Envelope»: Envelope1
Base = Base
Function я = Sin
Amplitude = 0 mm
Displacement = 70 mm
Frequency = 1
Phase = 0 deg.

1st «Filler»: Filler 
Envelope 1 = Envelope 
Envelope 2 = Envelope1
Function = Sin 
Direction = 
Groups = 10
Frequency = 16
Filling = 20%
Displacement = 0%
Lines in group = 3
	

2nd «Filler»: Filler1 
Envelope 1 = Envelope 
Envelope 2 = Envelope1
Function = Sin 
Direction =  
Groups = 10
Frequency = 16
Filling = 20%
Displacement = 50%
Lines in group = 2
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As a result we have created a background shown in ‘sample6_01.crb’. It consists of two «Fillers» created 
on the same «Envelope» but painted with different colors. So, the structure of a guilloche element becomes 
even more complicated, when «Fillers» are laid one over the other. Use Displacement to shift «Filler» lines. 
In our example, this parameter for the 2nd «Filler» is 50%. Another example of a background drawn by 
means of this method is given in file ‘sample6_011.crb’. Here three «Fillers» are created on the same 
«Envelope».
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When both linear and radial «Fillers» are used in one combination at the same time, a very interesting effect 
is produced. In this case to achieve a good result it is important to make sure the Groups and Frequency 
parameters are mutually coordinated. Let’s have a look at the following example.

To start with, create a new document in A5 format and prepare auxiliary elements as shown in the example 
above: a «Base» and two «Envelopes» Then, create two «Fillers» with the following parameters:

1st «Filler»: Filler 
Envelope 1 = Envelope 

Envelope 2 = Envelope1
Function = Cos
Direction = 

Groups = 18
Frequency = 12
Filling = -165%

Displacement = 0%
Phase = 180 deg.
Lines in group = 2

Phase in group = 90 deg.

2nd «Filler»: Filler1 
Envelope 1 = Envelope 

Envelope 2 = Envelope1
Function = Cos 
Direction = 

Groups = 24
Frequency = 9
Filling = 165%

Displacement = 0%
Lines in group = 2

Phase in group = 90 deg.
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In order to avoid chaotic overlay of «Fillers», the Groups and Frequency parameters are mutually 
coordinated. The number of the groups of the 1st «Filler» exceeds the Frequency of the second «Filler» 
twofold, and vise versa. If one of these parameters is changed, the whole guilloche element will change 
drastically. One more similar example is given in file ‘sample6_021.crb’.
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Two-colored and Multicolored Guilloches 

Guilloche protective level can be significantly increased in case of color printing 
in several runs. Each run is printed by a separate ink, so the final guilloche 
becomes multicolored. CERBERUS® allows creating multicolored complex 
guilloche images using positive and negative lines.

CMYK color model is used in the program to represent color. This model was 
selected as it allows more convenient distinguishing between the backgrounds 
by colors in layout programs. 

In the examples shown above we painted «Fillers» with different colors to 
distinguish between them. Creation of color guilloches doesn’t differ much from 
the creation of «complex» guilloches, considered before.

Task: Create a complex rosette and a two-colored background on your own.
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ShiftEffects

Using ShiftEffects option expands possibilities of «Fillers» creation. Frequency, amplitude and lines width 
modulation is possible based on the phase of individual lines.  
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UNIT 3. BASES, ENVELOPES
This unit goes into detail on application of various types of «Bases» and «Envelopes», and highlights use of 
the «Guilloche Wizard».

Available «Base» Types and Their Parameters 

CERBERUS® provides a wide variety of differently shaped base curves. It is possible to create variously 
shaped guilloche patterns on their basis. Some of these «Bases» are geometric figures, such as: Line 
segment, Ellipse, Polygon, Rectangle, Ellipse Arc, and Spiral. Such ornament figures as Lissajous and 
Evolvent are also available. A free form «Base» imported from any graphics editor would be also essential for 
free guilloche design creation. 

A new «Base» is created in the «Guilloche Manager». To start with, select the required «Base» type, at that, 
the created «Base» will feature default parameters. Each «Base» has its own unique name. Newly created 
«Bases» are named Base, Base1, etc. «Base» name can be changed by selecting it in the «Guilloche 
Manager».

The selected «Base» is highlighted in the working area. It is never saved in a PostScript file as it serves an 
auxiliary element. Click  icon with the left mouse button to make the «Base» displayed or hidden in the 
working area. Each «Base» has a type defined at the time of its creation. Parameters for each «Base» type 
are described further. 
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Line segment – 
«Base» in the form
of a line segment. 

Position – sets «Base» position 
in the working area.

Size – sets «Base» width and 
height in given measurement units.

Rotation Angle – sets the rotation 
angle of the «Base» relative to the 
given centre in degrees (0..360°).

Fragments – sets the number of 
fragments into which 

a «Base» will be split.
Nonlinearity – sets the number of 

parts to specify Nonlinearity of the 
elements built on this «Base».
 – turns on the mode of editing 

«Base» fragments. 
 – turns on the mode of setting 

nonlinearity in creation.

Ellipse – is a 
«Base» in the 

form of an 
ellipse. 
Position – sets width and 

height of the «Base».
Size – sets Width and Height 

of the «Base» in given 
measurement units.

Rotation Angle – sets the rotation 
angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the «Base» 
turns while the «Envelopes» 

are created on its basis at 
an angle of 0°.
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Polygon – is a 
regular polygon with 
the given number of 

sides.
Position – sets the «Base» position 

in the working area.
Size – sets the width and height 

of the «Base» in given 
measurement units.

Rotation Angle – sets the rotation 
angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the «Base» 
turns while the «Envelopes» are 

created on its basis at an 
angle of 0°.

Number of Sides – specifies the 
number of sides of the polygon.

Circumscribed – if the option 
is enabled, the polygon is 

circumscribed into an ellipse with 
the given parameters; otherwise 

these parameters determine Width 
and Height of a polygon.

Rectangle – is a 
«Base» in the form 
of a rectangle with 
Width and Height 

parameters.
Position – sets the «Base» position 

in the working area.
Size – sets the Width and 

Height of the «Base» in given 
measurement units.

Rotation Angle – sets the rotation 
angle of the «Base» relative to the 
given center in degrees (0..360°). 

Sliding Rotation – only the «Base» 
turns while the «Envelopes» are 

created on its basis at an 
angle of 0°.
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Polyline – 
this type allows 

importing lines in 
EMF and AI formats 
created in any graphics editor. 

A «Base» of this type can be 
edited directly in the working area.

Position – sets the «Base» position 
in the working area.

Size – sets the Width and Height 
of the «Base» in given 

measurement units.
Rotation Angle – sets the rotation 

angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the «Base»  
turns while the «Envelopes» are 

created on its basis at an 
angle of 0°.

 Reverse – changes the direction 
of creating the «Envelope» build 

on this particular «Base».
Closed – closes a polyline.

Arc of ellipse – is a 
«Base» in the form 
of an arc of ellipse.

 Position – sets the «Base» 
position in the working area.

Size – sets the Width and Height 
of the «Base» in given 

measurement units.
Rotation Angle – sets the rotation 

angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the «Base» 
turns while the «Envelopes» are 

created on its basis at an 
angle of 0°.

Arc starting point – sets the arc 
starting value in degrees.

Arc ending point – sets the arc 
final value in degrees.
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Oval – is a «Base» 
in the form of a 
rectangle with 

rounded corners.
Position – sets the «Base» 

position in the working area.
Size – sets the Width and 

Height of the «Base» in 
given measurement units.

Rotation Angle – sets the rotation 
angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the 
«Base» turns while the 

«Envelopes» are created on its 
basis at an angle of 0°.

Radius of Rounding is set by the 
User but cannot be more than 
half of the shortest side of the 

rectangle. 

Spiral is a «Base» 
in the form of 

spiral.
 
 

 Position – sets the «Base» 
position in the working area.

Size – sets the Width and 
Height of the «Base» in 

given measurement units.
Rotation Angle – sets the rotation 

angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the «Base» 
turns while the «Envelopes» are 

created on its basis at an 
angle of 0°.

Starting Coil and Ending Coil 
– sets the spiral part used for 

creating a «Base». 
Expansion – sets the spiral 

detorsion rate.
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Evolvent – 
a «Base» of 

this type is 
created on 
the basis of an earlier created 

«Envelope». 
Envelope – an «Envelope» created 
before that will be used for creation 

of a new «Base».

Lissajous – a 
«Base» is created 

on the basis 
of a Lissajous 

figure using previously defined 
«Functions». 

 Position – sets the «Base» 
position in the working area

Size – sets the Width and Height 
of the «Base» in given 

measurement units.
Rotation Angle – sets the rotation 

angle of the «Base» relative to the 
given center in degrees (0..360°).

Sliding Rotation – only the «Base» 
turns while the «Envelopes» are 

created on its basis at an 
angle of 0°.

Function X – sets the «Function» 
for creation in X-direction.

Function Y – sets the «Function» 
for creation in Y-direction.

Examples of various «Base» types are given in file ‘sample7_01.crb’.
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The Evolvent «Base» type has several peculiar features. It is impossible to create this «Base» in a new 
document, because it is built using an earlier created «Envelope». It means that in order to build a «Base», 
it is necessary to create an «Envelope» first. An example is given in file ‘sample7_02.crb’. In this example 
the «Base» Base1 is built with the help of the «Envelope» Envelope, which, in turn, is created on another 
«Base».

Guilloches created on Lissajous-type «Base» look quite attractive, see ‘sample7_04.crb’ as an example. To 
achieve the effect of overlaying, the «Base» was broken into three parts, and a filling was applied for the 
«Filler».
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To be able to create an arbitrary curve as a «Base», it is required to prepare it in advance in a graphics editor 
and save in EMS or AI format. After that such a curve can be imported into a CERBERUS® document and 
used as a standard «Base». It is also possible to edit curve node points in this type of «Base». An example 
of application is given in file ‘sample7_05.crb’.
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Guilloches with Different «Bases»

Sometimes, it is more convenient to use «Bases» to build «Fillers». So, in ‘sample7_06.crb’, the «Filler» 
is built with the help of two «Bases» – line segments. The  «Bases» edit mode allows changing the 
guilloche appearance quickly.
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A similar example with two imported curves is demonstrated in file ‘sample7_08.crb’.
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Sometimes, due to a specific shape of the curve, «Filler» is built irregularly along the length. This occurs 
most frequently when two curves have different length and run unevenly. 

For example, at an attempt to create a «Filler» on the lines, forming a «5», the result will be unexpected. 

However, after adjusting non-linearity parameter of the «Bases», the result will be quite acceptable – see 
‘sample7_09.crb’.
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Parameters and Application of Envelopes

«Envelopes» are lines created on the «Base» with the help of the «Functions» set by the User. The «Base» 
acts as some kind of a coordinate system for building a «Function». To create a new «Envelope» it is 
necessary to select the «Base» type (on which an «Envelope» will be created) in the «Guilloche manager». 
After that run command [New].

The «Base» and the «Function» used for building an «Envelope» should be created in advance. Every 
«Envelope» has its unique name. The newly created «Envelopes» are named Envelope, Envelope1, etc. It is 
possible to change the name of an «Envelope» by selecting it in the «Guilloche мanager».

Click icon  in the «Guilloche manager» with the left mouse button to have the «Envelope» displayed or 
hidden in the working area. To apply filling, click . Lines and filling color are set in Pen tool parameters.

The «Envelope» parameters are listed below 
 
Base – is the basis for creating an «Envelope»
Function – sets the «Function» that will be used for creating an «Envelope»
Amplitude – sets the amplitude of the «Function»
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Displacement – sets the relative distance between the 
«Function» and the «Base»

Frequency – sets the number of «Function» repetitions

Phase – sets the phase shift of the «Function» Inclination – sets the displacement direction of the 
«Function» relative to the «Base»
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Variable – sets the inclination rule set by the «Function»

«Envelopes» do not only serve as a basis for creating «Fillers», but they can be also used to create simplest 
guilloches, for example, ‘sample7_10.crb’.
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«Guilloche Wizards»

CERBERUS® allows using embedded patterns 
to create standard guilloches quickly. Guilloche 
Wizard is a set of tools that allows fast and easy 
creation of guilloche rosettes, borders, backgrounds 
and backgrounds with special effect. In practice, 
Guilloche Wizard is a set of ready-made guilloches; 
the User can modify some of their parameters.
The following Guilloche Wizards are available in 
CERBERUS®:

Rosette Wizard – serves to create guilloche rosettes.
Border Wizard – serves to create guilloche borders.
Background Wizard – serves to create guilloche 
backgrounds
Effects Wizard – serves to create guilloche 
backgrounds with effects. 
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The User selects the required guilloche type by clicking one of the offered images by the right mouse button. 
The current version of guilloche is in the center of the working area. Other images represent modified 
guilloches depending on the parameters selected in appropriate lists. Upper and right variants correspond to 
the decrease of the selected parameter, while the bottom and left ones - to the increase.

The User can select one of the suggested guilloches. The set of parameters for editing depends on the 
particular selected guilloche. The final guilloche variant is created with dimensions, set by Width and Height 
parameters. 
 
Task: Create a guilloche in the form of an «8» on your own.
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UNIT 4. «FUNCTIONS», IRREGULAR GUILLOCHES
«Functions» are of primary importance in guilloches design in CERBERUS®. The «Functions» set by the 
User determine the structure of a future guilloche pattern to a large extent. Apart from the pre-installed 
functions Sin and Cos, the User can create his own functions that will allow drawing a wide range of different 
guilloches. So, this unit looks at the creation of original «Functions» and their application techniques. 

«Functions» Setting Techniques 

Traditionally, curves composed of several different sinusoids 
were used to create guilloches. Mathematically, this 
combination of harmonic functions is described by Fourier 
series. Each harmonic conforms to a sinusoid or a cosine 
curve featuring a specific frequency. Harmonics are relative 
values and the function shape depends on their data. 
Examples of curves created from the «Functions» set by 
the Fourier series are given in Functions Library, ‘sample8_
01.crb’.
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We have already used standard pre-installed «Functions» Sin and Cos or ready-made «Functions» from the 
demonstration library ‘lib1.crb’. Now we will try to create various «Functions» on our own. 

«Functions» – are objects created by the User for determining curves, surfaces and effects. «Functions» are 
used for setting «Envelopes», «Fillers», getting various effects, and in other cases as well. 

The following methods of setting the «Functions» are realized in CERBERUS®: Fourier series, Formula 2D, 
Formula 3D, Bitmap and Interlaced.
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Functions Library contains a set of «Functions» available to the User in the current document.

«Functions» are grouped based on the «Function» setting method: Fourier series, Formula 2D, Formula 3D, 
Bitmap and Interlaced 

The following operations with «Functions» are available:
 

add a new «Function»

make a copy of an existing «Function»

show / hide «Functions» parameters dialogue window

show /hide «Functions» preview window 

delete a «Function»
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Each «Function» has its unique name. Newly created «Functions» are named Function, Function1, etc. It is 
possible to change the name of a «Function» by selecting it in the list of Functions Library. A «Function» is 
displayed in quick preview window . It is possible to set the number of preview periods for the «Functions» 
set by Fourier series and analytically by Formula 2D.
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Fourier series – the «Function» is specified by coefficients of Fourier series (harmonics)

,sin2sinsin 21 ntDtDtD n+++ 

( ) cos2coscos 21 ntCtCtCtx n ++++= 

,sin2sinsin 21 ntBtBtB n+++ 

( ) cos2coscos 21 ntAtAtAty n ++++= 

Fourier series parameters: 

Harmonics AB:
Used – the number of Fourier series components used for the calculation of Y (t) 
Value A – the current value of coefficient A selected for editing 
Value B – the current value of coefficient B selected for editing 

Harmonics CD:
Used – the number of Fourier series components used for the calculation of X(t) 
Value C – the current value of coefficient C selected for editing 
Value D – the current value of coefficient D selected for editing
Please note that only cosine curve harmonics (red color) should be used for creating symmetrical 
«Functions».

The maximum number of harmonics that can be used to describe a «Function» equals to 255. However, 
such number of harmonics is required quite seldom. Besides, as the number of harmonics grows, the time 
requited to calculate guilloche elements increases as well. That is why it is better to choose the minimum 
number of harmonics sufficient for reproduction of the «Function».
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Formula 2D – the «Function» is set by an analytical expression parametrically. 

In the analytic expression it is allowed to use constants, parameters, as well as the following operations and 
functions:
+, -, *, / – arithmetic operations
sin(), cos() – trigonometrical functions
abs() – absolute value
pi – value ¶ (PI)
exp() – exponential function
atan(x,y) – arc tangent 
sqrt() – square root

Formula 2D setting parameters:
Formula X(t) – Sets a component of the function X (t) parametrically 
Formula Y(t) – Sets a component of the function Y (t) parametrically
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Formula 3D – the «Function» of 2 variables is set by an analytical expression.

Formula 3D setting parameters:
Formula Z(x,y) – sets 2D «Function».
Coordinates:
Local – are used locally inside the «Filler».
Global – the coordinate system of the document working area is used.
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Bitmap – the «Function» is set by means of a bitmap image.

«Function» setting parameters:
File name – sets the bitmap image in BMP or TIFF format.
Apply Smoothing – the source bitmap image will be first processed by means of bicubic smoothing 
method. 
Include Image – saves a copy of the bitmap image in the internal CRB format.

Coordinates:
Local – are used locally inside the «Filler»
Global – the coordinate system of the document working area is used

Interlaced – a composite «Function» made of pre-set «Functions»
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Except apparent use of the «Functions» for the creation of curve lines in «Fillers» and «Envelopes», special 
«Functions» can be used to distort the «Filler», as shown in samples: sample9_01.crb – sample9_05.crb

These examples show how to achieve «Filler» deformation by using a special «Function» for the 
«Envelopes». In this case, distortions are achieved due to nonzero harmonics C and D used in setting the 
«Function».
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«Formula 2D»: Parameters, Application Options

When the User specifies «Functions» as Formula 2D, he enters mathematical expressions 
parametrically. This method is more universal than the Fourier series. At the same time, 
when using this method please take into account the following: firstly, calculations in case 
of the «Functions» set by a formula are made slower compared to Fourier series; secondly, 
the User should make sure his «Function» is periodic. 

«Functions» set by Formula 2D can be used to create «Envelopes», «Fillers». 

Let’s consider a particular case of using this «Function» to create a guilloche similar to the 
example given in ‘sample11_02.crb’. 
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To achieve this result, a curve was imported to create the «Base». «Envelopes» were created with the help 
of the «Function» set by the formula Y(t) = t*(t-1). This formula is nothing else but a parabolic equation.

The examples below were also created by means of the «Functions» set by Formula 2D.
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In CERBERUS® «Functions» are widely used for modulation of different «Filler» construction parameters 
such as frequency, filling %, lines width. To activate modulation of any parameter, tick the respective variable 
and set the «Function» for modulation.

In ‘sample12_01.crb’ «Filler» frequency was modulated, and in ‘sample12_04.crb’ – filling %.

‘Sample12_03.crb’ demonstrates concurrent modulation of frequency and filling by different «Functions», and 
‘sample12_05.crb’ shows how to achieve adjustment of lines width according to the specified «Function».
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Let’s consider the effect of creating a spirally shaped «Filler» on ‘sample13_01.crb’. This effect is achieved 
due to the modulation of «Filler» displacement parameter by function Y(t) = t.

‘Sample13_02.crb’ is of interest as «Filler» lines frequency modulation is applied there. Due to this, 
radial background density remains permanently constant. 
Without this correction lines density in the central part of the background would be much higher 
than at the periphery.
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«Formula 3D»: Parameters, Application for Irregular Guilloches

Setting the «Function» by means of Formula 3D is similar to what has been described above. The same as 
with Formula 2D, the «Function» is set by a mathematical expression but of a different type. In this case a 
two-variable function set by formula Z(x,y) = X(x,y) is used. 

Some examples of such «Functions» are given in file ‘lib3d.crb’.
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«Functions» set by Formula 3D have a mode of using the coordinate system. Either local or global 
coordinates can be chosen. Difference in application can be shown in ‘sample14_01.crb’.

Task: Create your own «Functions» library including original «Functions», set by various methods.
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UNIT 5. OVERLAYING IMAGES ON  
GUILLOCHE BACKGROUNDS 
This unit is dedicated to one of the most interesting capabilities of CERBERUS® – overlaying images on 
guilloche backgrounds by means of various techniques. To get the effects, the program allows using both 
double-level and halftone images. Further we shall consider methods and techniques of processing bitmap 
images and peculiarities of their application.

«Function» – «Bitmap», Preparing a Bitmap Image 

CERBERUS® supports a special «Function» to work with bitmap images. This special «Function» is called 
Bitmap and represents a function of two variables, the values of which are set basing on the graylevel of a 
bitmap image in the respective pixel. 

The program supports images in BMP and TIFF formats (without compression). Such images can be created 
using various graphics editors. Black-and white, gray and color images are acceptable, but in the program 
they are converted into Grayscale format.

Resolution value of bitmap images at their creation is worth mentioning separately. Low resolution can 
affect detailing the reproduced image badly: «saw» effect can appear and fine details can disappear. High 
resolution leads to a significant consumption of computer RAM and slowing down calculations. The optimum 
choice would be resolution within the range of 150 to 300 dpi. 

A bitmap image file can be saved anywhere on the disk, but when a crb-document is moved to another 
computer, links with the bitmap image can be broken. That is why it is better to save a crb-file and image files 
in one folder. Besides, it is possible to include a bitmap image copy in a crb-document file, but this leads to 
increasing the file size. 

It is possible to smooth the loaded image a little by ticking Smoothing and adjusting Brightness and Contrast.
The values of coordinates parameters are similar to those of the «Functions» set by Formula 3D.
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Modulating «Filler» Parameter, Local and Global Coordinates 

Now we will consider some examples of overlaying bitmap images on guilloche backgrounds. Let’s take 
symbol «A» from file ‘a.tif.’ as the source image. Then, we will create a new «Function» of Bitmap type, 
choosing our file a.tif in the course of creation. After this we will prepare a simple background for overlaying 
our image. Please note the background should be dense enough, otherwise the image will develop badly.

The distance between the background lines should be about one millimeter or less. Image development 
on the background also depends on the contrast of the source image, availably of fine details, modulation 
parameters, background lines width and background structure. 
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In the example given in ‘sample15_001.crb’ the image is reproduced on the background due to the 
modulation of «Filler» frequency from 50 to 150. 

In ‘sample15_002.crb’ the image is also reproduced due to frequency modulation, at the same time a 
grayscale image was used as a source image. 
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More examples on «Filler» modulation are available in ‘sample15_003.crb’ and ‘sample15_004.crb’.
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It is possible to get the so-called «embossed» backgrounds by means of displacement modulation, as shown 
in ‘sample15_005.crb’ and ‘sample15_006.crb’.
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Images on backgrounds in ‘sample15_008.crb’ and ‘sample15_009.crb’ were created due to the modulation 
of «Filler» lines width.
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Unfortunately, due to the poor monitor resolution it is impossible to render the effect of image overlaying 
exactly as it will look in printing. In the examples below the lines were made wide to make the image visible 
on the monitor. In practice, width should be set within the range of 0.04 mm to 0.1 mm. Please note the 
starting value and increment are specified in «Filler» parameters instead of the starting and final values. 

Now let’s consider application peculiarities of local and global coordinates when using the «Function» - 
Bitmap image. In ‘sample15_010.crb’ and ‘sample15_011.crb’ local coordinates are used to place the words 
circle-wise. 
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Combined Use of Modulation with Different «Functions»

CERBERUS® allows simultaneous application of modulation of different parameters for one and the same 
«Filler» providing much more freedom for creativity and enabling creating original guilloche backgrounds with 
images. 

For combined parameters modulation it is required to prepare the images first and create the respective 
«Functions» on their basis.

So, ‘sample15_013.crb’ contains three images that are overlaid on one and the same background  in 
different ways: by modulating «Filler», frequency and lines width. Sample15_016.crb, however, demonstrates 
that the effects can easily overlap.
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Modulation is applicable to combined guilloches as well. In this case, it is necessary to specify modulation 
parameters for each «Filler», at that it is not required to duplicate the «Function». ‘Sample15_017.crb’, 
‘sample15_018.crb’ and ‘sample15_019.crb’ demonstrate options of combined guilloches application for 
overlaying images.

Task: Create a background with a logo and an inscription.
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UNIT 6. PRACTICAL TECHNIQUES 
This unit touches upon some practical techniques of creating guilloche elements; gives examples of using 
fillings. The unit will also highlight creating overlapping guilloches and pseudo-engravings in CERBERUS®. 
Use of microtext will be touched upon as well.

Application of Fillings for «Envelopes» and «Fillers»

CERBERUS® supports fillings creation for guilloche elements. This capability makes further processing 
of guilloche elements when assembling general composition of the protected document much easier and 
less time consuming. For example, it is frequently required  to place a rosette over a background. The task 
doesn’t look difficult. At the same time a question arises: how to remove the background from under the 
rosette? If the rosette has a sophisticated structure the task becomes even more complicated.

CERBERUS® can solve such tasks. All you have to do is enable filling of the «Filler».
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Let’s consider some other methods of fillings application in creating guilloches. Sample 16_001.crb 
demonstrates a version of an «impossible» figure composed of three rosettes of different colors. Color is 
used for better visualization only.



page 107

The trick of this example is as follows: the «Base» on which the red rosette is created is broken into 
fragments that are output in a certain order.
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Sample16_002.crb was created following the same principle.
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Overlaying Guilloches 

Application of fillings and breaking a guilloche element into fragments enable creating «jelloped» guilloches 
similar to ‘sample16_003.crb’. The trick is also in using fragmentation of the «Base» that is employed for 
creating «Fillers».

Bands of both «Fillers» look unbroken, but in fact they consist of separate pieces that are displayed on the 
monitor in turn. Besides, when this image is later exported to AI format, separate fragments become grouped 
which allows changing their relative positions easily. 

The example of a «jelloped» guilloche given in ‘sample16_004.crb’ where several «Fillers» are used 
concurrently looks particularly striking.
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Creation of Engravings, Image Modulation with Various Hatching, Masks Application

In Unit 5 we have already tried to place images on guilloche backgrounds. To achieve resemblance with 
engraving, let’s use the following technique. The process of creating a pseudo-engraving will be described in 
‘sample16_005.crb’. 

Let’s create a simple background and modulate «Filler» lines width. For better visualization on the monitor 
lines width varies from 0.04 to 0.5 mm. After that let’s copy the whole guilloche group and expand the 
«Base». The color of the copied «Filler» is changed to white. In order to have the white lines present only in 
the light parts, let’s use masking with the help of the same Function that was used to modulate the image. 
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As a result, we will have an image, the light parts of which are shown with hatched lines.
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Then, we will create another «Filler» with black lines, but use the inversion Function as the mask. This will 
allow getting crosshatching lines in the shade.
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This example is rather simple. In practice, to achieve an acceptable result, a much greater number of 
«Fillers» and masks is usually required. For example, seven «Fillers» with various prepared masks were 
used to create the pseudo-engraving image of a squirrel. In any case, this is very time-consuming work that 
requires high qualification.
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Modulation of Images by Variable Dotted Lines 

CERBERUS® allows using lines consisting of separate hatches as «Filler» lines; it is also possible to 
modulate hatching parameters. An example is given in ‘sample16_008.crb’. This effect is achieved due to 
selecting the Dotted line style and modulating the off-duty factor of hatched lines. 
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Microtext: Parameters and Application Features 

 Application of Microtext is characterized by special features. CERBERUS® allows employng a User-defined 
text string as a «Filler». To this end, select Microtext style in «Filler» properties. Please note that the height of 
text characters should not be less than 0.1 mm. Smaller characters cannot be displayed.

It is advisable to use sans serif fonts, for example Arial. The program supports using fonts in Type1 format 
(filename extension *.pfb). 

If no font is selected, the standard system font is used, and when a document is exported into a Postscript-
file, there will be only a reference to it. Type1 format font is embedded into a Postscript- file entirely.

It is possible to reproduce images with the help of mictotext. It is done by means of characters height 
modulation or changing the interval between the characters. An example is given in file ‘sample16_009.crb’.
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Mictotext lines can be used along with usual solid lines, as shown in ‘sample16_010.crb’.

Task: Master your filling skills. Create a two-colored background with microtext elements and a central 
sophisticated rosette.
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UNIT 7. «FILTERS»
This part of the User Guide concentrates on «Filters» application in CERBERUS®. It describes «Filters» 
purpose, provides a list of available «Filters» and considers application examples.

The notion of «Filters»

CERBERUS® provides the Users with a powerful tool for creating effects. «Filters» are objects producing 
some manipulations with guilloche elements in order to achieve some graphic effect. As a rule, a «Filter» 
transforms the lines that compose a guilloche pattern. 

 «Filters» are managed with the help of «Filters» dialogue window. This window can be called up from the 
main program menu or with the help of icon  in the toolbar. It is possible to set the order of «Filters» 
application by dragging the respective items from the list by the mouse. Ticked «Filters»  are active and 
are used by creation. It is possible to use «Filters» of the same type simultaneously.
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Available «Filters»

«Filters» available in CERBERUS® are listed below: 
Filter «Emboss» – creates embossed images; 
Filter «3D-surface» – overlays a guilloche on 3D-surface; 
Filter «Frame» – for fast frames creation; 
Filter «Kaleidoscope» – provides kaleidoscope effect; 
Filter «Double line» – protects guilloches against photocopying; 
Filter «Variable width»- overlays images on a guilloche;
Filter «GrayCopy» – protects guilloches against photocopying;
Filter «Jitterprint» – for creation random micro displacement of the lines.

Creates a new «Filter». When a new «Filter» is 
created it is requested to select its type from the 

dialogue window. 

«Filters» Properties. Calls up the dialogue window 
with parameters of the selected «Filter».

Switches into the mode of interactive editing of 
«Filter» parameters (with the mouse). 

Deletes the selected «Filter».
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Filter «Emboss» is designed to create embossed images. The effect is achieved due to displacement of the 
source guilloche lines under a User-specified rule.

«Filter» Parameters: 

Function X – Defines the function, according to which the lines will be displaced along axis X.
Function Y – Defines the function, according to which the lines will be displaced along axis Y.

Displacement X – Sets the value of lines displacement along axis X.
Displacement Y – Sets the value of lines displacement along axis Y.

«Filter» Effect:
 
1. Source guilloche image.	2 . Function for mask setting.	 3. «Filter» application result.
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Filter «3D-surface» overlays the source guilloche image over a 3D-surface. This results in distortion of the 
source image. This «Filter» allows creating irregular guilloches.

«Filter» Parameters:

Definition – defines the form of a 3D-surface.
Z = X(t)+Y(t) – specifies the surface as a sum of two functions of one variable. 

For example, Fourier series or Formula 2D.
 Or Z = F(x,y) – specifies the surface by the function of two variables. 

For example, Formula 3D or Bitmap Image.
Coordinates – sets the 3D-surface position in space.

Sizes – sets the 3D-surface sizes.
Camera – defines the viewer’s position relative to the 3D-surface.
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«Filter» Effect:

«Function» for setting a 3D-surface. 
In this case Formula 3D – type is applied.

1. Source guilloche image.	2 . «Filter» application result.
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Filter «Frame» is designed for fast creation of a rectangular frame of given dimensions.

«Filter» Parameters:

Width of module – Sets the height of a trapezium for creating a frame corner.
Length of module – Sets the length of a trapezium for creating a frame corner.

Position X – Sets the frame position along axis Y in the working area.
 Position Y – Sets frame position along axis Y in the working area.

Width of frame – Sets the frame width.
Height of frame – Sets the frame height.

«Filter» Effect:
 
1. Source guilloche image.	2 . «Filter» application result.
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Filter «Kaleidoscope» is designed to rotate, reflect (mirror reflection) and duplicate a separate guilloche 
element limited by a triangle. As a result a new guilloche of a kaleidoscope type is created.

«Filter» Parameters:

Size – Sets the size of a triangle for a kaleidoscope.
Position X – Sets the triangle position along axis X in the working area.
Position Y – Sets the triangle position along axis Y in the working area.

Filling of all sheet – The newly created pattern will be multiplied to fill the whole working area.

«Filter» Effect:
 
1. Source guilloche image.		2 . «Filter» application result.
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Filter «Double line» applies the following operation to the source guilloche image: composite lines are split 
into two components. The splitting area is set by a User-defined «Function». As a result some parts of the 
guilloche image will consist of double lines; lines width is less compared to the source line.

Function – a User-defined «Function». Sets the splitting area of the source line. 
Min width – Minimum width of the source line to which the «Filter» will be applied.
Displacement – Distance at which the new lines will be moved apart (gap value).

New width – Relative size of the new line compared to the source one. It is selected based on 
experience within the range of 30 to 50% depending on dot gain at printing. 

«Filter» Effect:
 
1. Source guilloche image.	2 . Function for mask setting.	 3. «Filter» application result.
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Filter «Variable width» is designed for overlaying images on guilloche elements. The effect is achieved due to 
changing guilloche lines width.

Filter Parameters: 

Function – Defines the function, according to which lines width will be changed. 
Min width – Defines the minimum line width of the new image.

Max width – Defines the maximum line width of the new image.

«Filter» Effect:
 
1. Source guilloche image.	2 . Function for mask setting.	 3. «Filter» application result.
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Filter «GrayCopy» applies the following action to the source guilloche: lines color brightness and lines width 
change under a certain rule. Also, a hidden image is formed that will develop by photocopying. The level to 
which the color brightness and lines width will change is set by the «Function» set by the User. As a result 
of the «Filter» application some parts of a guilloche image will consist of lighter but wider lines while the 
average brightness value of the image part will remain unchanged.

«Filter» Parameters:

Function – is the «Function» specified by the User. It specifies the rule under 
which color brightness and width of the source lines will change.

Multiplier – this parameter determines the value by which the line width will 
increase and, respectively, color brightness of the source line will decrease.

Correction % – enters correction by setting color brightness.
 Calibration – allows compiling a calibration table for selecting the most 

suitable correction value for a particular print process. 

«Filter» Effect:
 
1. Source guilloche image.	2 . Function for mask setting.	 3. «Filter» application result.
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Filter «Jitterprint» is for creation of modulated images on a guilloche background due to lines irregularity.  
The effect is achieved due to random micro displacement of the lines, as well as due to lines width 
modification.

When using Jitterprint «Filter» guilloche lines become «jittery». The effect is achieved due to random lines 
displacement (“saw» effect), as well as due to random lines width modification.  It is possible to apply 
masking to achieve the effect in the local area.

«Filter» parameters:

Jitter – specifies maximum lines deviation value. 
Jagging – specifies maximum lines width modification value. 

Masking – sets the mask «Function» for «Filter» use.  

«Filter» Effect:
 
1. Source guilloche image.	2 . Function for mask setting.	 3. «Filter» application result.
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Combined Application of «Filters»

A useful «Filters» feature is that they can be used together in random sequence to achieve the required 
result. Each subsequent «Filter» modifies the guilloche element. As a result the source image can change 
greatly. 



page 130

As an example, let’s consider guilloche creating process from file ‘sample17_013.crb’. As a starting point, the 
simplest rosette was taken. Then the following «Filters» were applied to it one by one: Kaleidoscope, 3D-
surface, Frame and Variable Width.

Task: Create a guilloche composition using «Filters».



page 131

unit 8. 
optimization and further 
guilloches processing

general provisions 3
system requirements 4

UNIT 1. GENERAL INFORMATION 6
UNIT 2. COMPOUND AND COMBINED GUILLOCHES  41

UNIT 3. BASES, ENVELOPES 61
UNIT 4. «FUNCTIONS», IRREGULAR GUILLOCHES 78

UNIT 5. OVERLAYING IMAGES ONGUILLOCHE BACKGROUNDS  95
UNIT 6. PRACTICAL TECHNIQUES  105

UNIT 7. «FILTERS» 118
UNIT 8. OPTIMIZATION AND FURTHER GUILLOCHES PROCESSING 132



page 132

UNIT 8. OPTIMIZATION AND FURTHER  
GUILLOCHES PROCESSING
In the final part we will give some recommendations on efficient creation and further use of guilloches in 
CERBERUS®. For this purpose you’ll need a vector graphics editor that allows importing graphic images in 
PostScript-format, for example, Adobe Illustrator or CorelDraw!

Reducing Time for Creating Guilloches 

Creation of any sophisticated guilloche is a time-consuming process that requires considerable computer 
capacities as well. Creating a guilloche is like a search for the desired result where one has to try many 
options. 

Some tips on optimizing the guilloche creation process are given below: 
•	 Before creating a guilloche element, first set its dimensions and the respective format of the working area.
•	 Start with simple elements.
•	 Do not try to place several guilloche elements in one document at the same time.
•	 Where possible, disable preview of the elements not required at this particular moment, especially 
	 «Filler» elements.
•	 Do not misapply automatic calculations when entering parameters, especially for 
	 sophisticated guilloches.
•	 Set the quality parameter to the minimum value for preview and the required value – for export.
•	 Do not use unnecessary harmonics when setting «Functions». 
•	 When creating a background of a big size first create a smaller sample background. Then make 		
	 calculations for the final variant by increasing lines in group and «Filler» frequency proportionally.
•	 Do not use «Filler» fillings if not required.
•	 It is better to fragment fillings for complex «Fillers».
•	 Set the required lines width from the beginning, otherwise you will have to change it in layout programs. 
•	 Select and save guilloches versions you are happy with – it is always easier to modify than create 		
	 something new.
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Export of Guilloches, Potential Difficulties 

The final operation of creating a guilloche element in CERBERUS® is export of graphic information to 
PostScript, EPS or Adobe Illustrator format. 

When the result is saved in *.EPS format, a bitmap image is added to the file for preview in layout programs 
(Preview).

When saving the results, it is necessary to specify the following parameters:

Quality – defines curve reproduction accuracy 
Cutting off – determines the top left and the bottom right angle of a rectangle for cutting off 

Use PS clip – the «clip» command of PostScript will be applied at output, as a result all 
information beyond the working area will be cut by RIP.
Scale – determines the scale of the new PostScript file. 

You can set the scale to 1:1 or to 1:10 (multiplied by 10), or User-defined. 
 PS Optimization – parameters for PostScript-file optimization. 

Number of points in curve – the maximum possible number of curve node points 
Clean unnecessary points – approximation of curves with the 

specified Accuracy will be performed.
To unite curves – short curves of the same color and width will be combined into one curve. 

The total number of points in the resulting curve is not constant.
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After entering the required parameters, a PostScript file is created by clicking the |OK| button.

When exporting a created guilloche to Adobe Illustrator, specify the scale 1:1, and when exporting to 
CorelDraw! – 10:1 with further minimization in this editor. 

Parameter Quality directly affects the calculation time and the size of the created file, so it is not 
recommended to increase it when not required. Parameter Number of points in curve is also important: some 
imagesetters can have problems when processing curves with a big number of curve node points. 
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Protection against Unauthorized Access 

CERBERUS® provides protection against unauthorized program launch. The program works only provided 
the User has the electronic key and enters the right password set at the program installation. 

The program provides files protection by encoding the contents. It is impossible to open such files without 
knowing the password. 

Protection of PostScript files, as well as other temporary files with guilloche elements, against unauthorized 
access is up to the User.
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CONCLUSION 

After reading this User Guide and completing the tasks given at the end of each unit you have learned to 
create guilloche elements in CERBERUS®. The examples demonstrate only a small part of the program 
capabilities. Of course, a lot depends on your imagination and experience you will eventually get.

Good luck!


	general provisions
	system requirements
	UNIT 1. GENERAL INFORMATION
	The Principle of Drawing Guilloches in CERBERUS® 
	Terms and Definitions Used in CERBERUS® 
	Program Interface 
	Main Menu 
	«Quickbars»
	Guilloche Manager 
	Creating a Simple Guilloche on the model of Rosettes 
	Creating a Border 
	Creating Backgrounds 
	UNIT 2. COMPOUND AND COMBINED GUILLOCHES 
	Principles of Creating Compound Guilloches 
	Radial «Fillers»
	Creating Combined Guilloches 
	Two-colored and Multicolored Guilloches 
	ShiftEffects
	UNIT 3. BASES, ENVELOPES
	Available «Base» Types and Their Parameters 
	Guilloches with Different «Bases»
	Parameters and Application of Envelopes
	«Guilloche Wizards»
	UNIT 4. «FUNCTIONS», IRREGULAR GUILLOCHES
	«Functions» Setting Techniques 
	«Formula 2D»: Parameters, Application Options
	«Formula 3D»: Parameters, Application for Irregular Guilloches
	UNIT 5. OVERLAYING IMAGES ON GUILLOCHE BACKGROUNDS 
	«Function» – «Bitmap», Preparing a Bitmap Image 
	Modulating «Filler» Parameter, Local and Global Coordinates 
	Combined Use of Modulation with Different «Functions»
	UNIT 6. PRACTICAL TECHNIQUES 
	Application of Fillings for «Envelopes» and «Fillers»
	Overlaying Guilloches 
	Creation of Engravings, Image Modulation with Various Hatching, Masks Application
	Modulation of Images by Variable Dotted Lines 
	Microtext: Parameters and Application Features 
	UNIT 7. «FILTERS»
	The notion of «Filters»
	Available «Filters»
	Combined Application of «Filters»
	UNIT 8. OPTIMIZATION AND FURTHER GUILLOCHES PROCESSING
	Reducing Time for Creating Guilloches 
	Export of Guilloches, Potential Difficulties 
	Protection against Unauthorized Access 
	CONCLUSION 
	general provisions
	system requirements
	UNIT 1. GENERAL INFORMATION
	UNIT 2. COMPOUND AND COMBINED GUILLOCHES 
	UNIT 3. BASES, ENVELOPES
	UNIT 4. «FUNCTIONS», IRREGULAR GUILLOCHES
	UNIT 5. OVERLAYING IMAGES ON GUILLOCHE BACKGROUNDS 
	UNIT 6. PRACTICAL TECHNIQUES 
	UNIT 7. «FILTERS»
	UNIT 8. OPTIMIZATION AND FURTHER GUILLOCHES PROCESSING

